Page 1 of 1

poe hat fan control

Posted: Fri Feb 19, 2021 4:46 pm
by jaffascout
Hello everyone, thank you for allowing me to use this forum.

I am running
RPI4 4gb
os is the standard download of nems GNU/Linux 10 (Buster)
nems ver. 1.5.2
build C03112
firmware #1399

i am wishing to deploy the nems server out of the office so have kitted the pi with a poe hat to reduce the cables required.

however the temp of the pi seems to keep going up and on inspection the fan does not spin.
if i boot the pi there is a small wobble of the fan when i connect the rj45 but nothing after.
temp is getting to 61 degrees with no fan action.
does anyone know how to resolve this and aim to keep the pi below 50 degrees.

Just tried to check the temp from terminal and the check_sbc_temperature doesnt work or cant be found?

Many thanks in advance.
Jaffa

Re: poe hat fan control

Posted: Fri Feb 19, 2021 7:13 pm
by Marshman
Hi jaffascout,
Robbie is looking into this for you. Hang tight and look for an update soon.

Re: poe hat fan control

Posted: Fri Feb 19, 2021 7:19 pm
by jaffascout
Hiya,
Thank you for the update.
I didn't expect anyone to be so on the ball.

finding this quite stressful i hope there is a simple solution

Re: poe hat fan control

Posted: Fri Feb 19, 2021 8:02 pm
by jaffascout
Marshman wrote: Fri Feb 19, 2021 7:13 pm Hi jaffascout,
Robbie is looking into this for you. Hang tight and look for an update soon.
quick update....
I have found a fix that works for now,

$ sudo SKIP_KERNEL=1 rpi-update 32f92809

after the reboot the fan is working and the temp is now coming down.

dmesg found this. 5.766828 rpi-poe-fan [email protected]; failed to get default PWM value; -5

i am guessing the rpi kernel update was faulty that was included in the nems update.

al appears to still be working i have all my hosts and services, and the fan is running, temp now stable at 50.15 degrees Celsius

Re: poe hat fan control

Posted: Sat Feb 20, 2021 4:44 pm
by Robbie Ferguson
Thanks for posting the fix you implemented. When Marshman brought the thread to my attention yesterday, I ordered a PoE hat and injector so I could do testing and implement a fix. Those will arrive this coming week, so I'll dig into it in the coming days and will integrate a permanent fix in NEMS Linux 1.6, which is currently in testing and will hopefully release publicly soon[ish] :)

Re: poe hat fan control

Posted: Mon Feb 22, 2021 1:33 pm
by jaffascout
Hi Robbie,

Thank you for taking the time to investigate, the fix is holding up so far.
I am no way clever enough to be sure on this but the fix was discussed in an RPI forum i found - same problems with no fan activity so i am guessing the original fault was written in by PI writers?

Dont know if this is of any help what so ever, but better shared than not .

Thak you for all you efforts the nems server is just ace.