No rrd directory after clean install of 1.5.2 Build 1 on RPI4

Having issues? Post them here, and help other users.
Post Reply
erolando
Junior Member
Posts: 1
Joined: Mon Sep 27, 2021 12:32 pm

No rrd directory after clean install of 1.5.2 Build 1 on RPI4

Post by erolando »

Hi all

I just installed NEMS 1.5.2 Build 1 on a RPI4.

Graphs @ "Nagios Core" gives me "Cannot read rrd directory /var/nagiosgraph/rrd".
Nagiosgraphs (from dashboard/reporting) also give the same error.

The directory does not exist at all.

There is a "/usr/local/nagios/nagiosgraph" dir, with etc and var subdirs.

Code: Select all

@nems:/usr/local/nagios/nagiosgraph/var $ ls -l
total 4
-rw-rw-r-- 1 www-data root      0 Sep 27 12:19 nagiosgraph-cgi.log
-rw-rw-r-- 1 root     root      0 Sep 27 12:19 nagiosgraph.log
drwxr-xr-x 2 nagios   nagios 4096 Sep 27 12:19 rrd

@nems:/usr/local/nagios $ grep -r "/var/nagiosgraph/rrd" *
nagiosgraph/etc/nagiosgraph.conf:rrddir = /var/nagiosgraph/rrd
There seems to be a config error somewhere or maybe there is an installation step missing.
I reinstalled everything from scratch, same problem.

Any ideas?
Thanks!
Esteban
LMarr[DK]
Junior Member
Posts: 1
Joined: Wed Nov 03, 2021 10:05 pm

Re: No rrd directory after clean install of 1.5.2 Build 1 on RPI4

Post by LMarr[DK] »

Same problem here :-(
I have a couple of temperatures i monitor, and I really miss the graphs :-(

I am hoping for an update, or fix, soon :)


Last bumped by LMarr[DK] on Tue Nov 23, 2021 10:53 pm.
Post Reply