Page 1 of 1

NEMS 1.5.2 Pi 4B 2GB

Posted: Tue Mar 15, 2022 6:32 am
by jnsdion

I have downloaded NEMS from the website, created the image on a 16GB SD card but when I try to boot it in my Pi4 B I get the following:

start4.elf: is not compatible
This board requires newer software
Get the latest software from

I am a bit rusty but the card is fine, is I burn Raspberry PI OS onto it there's no problem but can't book with the NEMS image :(

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Tue Mar 15, 2022 6:14 pm
by Marshman
Yeah, this has become a problem since the Raspberry Pis came out with newer firmware to allow booting from USB drives. If possible, boot the Pi using the RaspberryPi OS. Connect a USB drive to the Pi and copy all of the .dat and .elf files from the /boot directory. Then plug that USB drive and the sd card into your PC and copy those files into the /boot directory on the sd card overwriting all. Then try booting the Pi from the sd card.
Alternatively, you can go here: and grab the boot folder files and transfer over the .dat and .elf files to the sd card. Make sure you transfer and overwrite ALL of those files, about 22MB worth.
Hope that works for yopu.

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Thu Apr 07, 2022 2:41 pm
by Mo00
I have the same problem and tried all this and it didn't work :( :(

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Sat Apr 09, 2022 6:04 am
by Marshman
Try these steps:

Getting the Pi 4 to NEMS 1.5.2 boot

If the Raspberry Pi has not been updated you will need to have a micro sd card flashed with Raspberry Pi OS to boot the pi and do updates. If Pi eeprom and firmware already updated skip
to Step 4. If unsure, continue.

1) Boot the Raspberry Pi from the microSD card with Raspberry Pi OS.

2) Open Terminal in Raspberry Pi OS (Note: you can do these steps from another computer via SSH if you want to set up the Pi headless).

3) Run the following commands:

sudo apt update
sudo apt full-upgrade
sudo rpi-update
sudo reboot

sudo rpi-eeprom-update -a
sudo reboot

vcgencmd bootloader_version

This should output something like:

pi@raspberrypi:~ $ vcgencmd bootloader_version
Jul 16 2020 16:15:46
version 45291ce619884192a6622bef8948fb5151c2b456 (release)
timestamp 1594912546

**The date can be anything like July 16 2020 OR LATER!**

4) Open a terminal and run sudo raspi-config

5) Select 6 Advanced Options, Select A6 Boot Order, Select B1, select OK, Reboot

6) Shut down the Pi. Then unplug the microSD card.

7) On your PC, flash the NEMS image onto you choice of drive.

8) Before you eject the boot volume, you need to replace some files on it with the latest versions from GitHub. If flasher software auto ejected the drive, unplug and plug it back in

9) Go to the raspberrypi/firmware GitHub repository ( and download the zip or clone the project to your computer (get the default master branch).
Or use this one-line command - ... 8f65b0b1fa - to just grab the necessary files without the entire repository.)

10) Inside the boot folder, copy over all the files that end in .elf or .dat to the boot volume of your NEMS drive (replace the same-named files that already exist there - it should
total about 22MB.

11) Eject the boot volume, and unplug the NEMS drive.

12) Plug your NEMS drive into you RPi

13) Power up the Pi, and after a coupple of minutes or so (it has to expand the USB drive to fill the volume and then reboot), it should boot up!

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Sat Apr 09, 2022 11:26 am
by Marshman
Get the files from here and overwrite the files in the /boot folder: ... B_boot.git

The files from the Raspberry Pi GitHub site no longer work for NEMS 1.5.2

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Sun Aug 07, 2022 8:22 pm
by JimmieJoyce
I've done it the way above but it's probably having a problem somewhere. bubble shooter

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Sat Aug 27, 2022 3:38 pm
by riccardo
Also not working (RPi 4b 2 Gb)
Did updates for RPi.

tested with 64Gb USB and 32Gb SD-card (Sandisks)
Also copied these 16 files to root (bootdisk)
He says: No firmware found
Invalid ELF header: start.elf ... ain/ElfDat

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Tue Sep 27, 2022 4:42 am
by sneezestew
I also have this issue and have tried all of these solutions without successfive nights at freddy's

Re: NEMS 1.5.2 Pi 4B 2GB

Posted: Sun Feb 12, 2023 11:05 am
by Marshman
NEMS Linux 1.6 has been released and should fix this issue. Get it here: ... y-pi-4.php